miércoles, 5 de junio de 2019

DNIe en Fedora 30. Cada vez más sencillo

Hace algunos años decía en una entrada que la única necesidad de mantener un ordenador con Windows era poder utilizar los lectores de DNIe. Eso era hace mucho tiempo, y desde hace algunas distribuciones —ni me acuerdo de cuántas— tengo instalado el software necesario para poder utilizar el DNIe en Fedora. La guía más útil que he encontrado en estos días tras la instalación de Fedoa 30 es la más reciente de atareao. Para nosotros los usuarios de Fedora tiene algún defectillo; atareao es usuario de Ubuntu (nada es perfecto) y en mi instalación de hoy he visto que algunos de los paquetes indicados no son necesarios, al menos en Fedora; aún así en una guía muy útil y bien documentada. Vamos a resumir los pasos necesarios para preparar el uso de un lector de DNIe (u otras tarjetas similares) en un ordenador con Fedora 30.
1. El software para Linux del DNIe lo bajamos del Cuerpo Nacional de Policía. La versión disponible en nuestro caso es un binario rpm para Fedora 28, pero funciona perfectamente.
Este software, tiene dependencias, en concreto señala:

error: Error de dependencias:
    pcsc-lite es necesario por libpkcs11-dnietif-1.5.0-1.x86_64

2. Eso nos lleva a la instalación de pcsc-lite, que en su instalación

su -c 'dnf install pcsc-lite'

instala también pcsc-lite-ccid

y luego


su -c 'dnf install libpkcs11-dnie-1.5.0-1.x86_64.rpm' # en el directorio donde lo tengáis


3. Conectamos el lector y hay que configurar Firefox. En Preferencias, Privacidad & Seguridad, Certificados, picamos en Dispositivos de seguridad.
Ahí deberemos cargar un módulo nuevo, con el nombre que nos parezca mejor y localizar el fichero libpkcs11-dnietif.so (en mi caso, instalada la versión de 64 bits, estaba en/usr/lib64; en la versión de 32 bits estará en /usr/lib)


Y listo. Podemos picar en iniciar sesión o simplemente introduciendo el DNI y picando en algún enlace que lo precise nos pide la palabra clave que protege el certificado.

Atareao indicaba la necesidad de instalar
pcsc-tools - en mi caso no ha sido necesario
pcscd - en Fedora no existe con ese nombre; es pcsc-lite
libccid - en Fedora es pcsc-lite-ccid
pinentry-gtk2 - en Fedora solo existe en repositorios pinentry-gtk y en mi caso ya estaba instalado previamente

Ha funcionado perfectamente en los dos lectores de los que dispongo, un SCM Microsystems SCR3310 v2.0 de los que regalaban con los primeros DNIs electrónicos y el C3PO LTC31 que pone mi Universidad a mi disposición.

Una necesidad menos para mantener Windows.

No hay comentarios:

Publicar un comentario